When using the ls command to display size of files, you display file sizes and directory sizes in Kbytes, Mbytes, Gbytes, or Tbytes (when the file or directory size is larger than 1024 bytes) using:
-s
-h
-ld
-l
If an adjustment in the /etc/system file has rendered your system unbootable, what command would you use to recover?
rec path -r
ok boot -a
restart ok -a
boot.ok.a
To verify that a certificate was not altered en route, you use the fingerprint (digest):
All are correct
MD5
SHA1
None are correct
Which of the following command can be used to add new user accounts to the local system?
moduser
useradd
adduser
usermod
Under the Solaris Operating System, are double-quotes, left single-quotes and right single-quotes interchangable?
No. Command
syntax must be exact.
Solaris doesn't use quotes.
Quotes are only used to mark text for reference and
not read by the compiler.
Yes, but only double quotes and left-single quotes
are interchangeable.
How to check filesystem damage?
ck
fsok
fsck
sync
What is ZFS?
A terminal emulator.
A framework for using MS Dos.
A file system
used by Solaris.
An operating system existing within Solaris.
What is the difference between ARC and L2ARC?
L2ARC runs slower.
There is no difference.
ARC is stored on a cloud environment.
ARC is the
primary cache, and L2ARC is the secondary cache.
Which of the following act as an interface between the user and the kernel?
RAM
Kernel
Shell
Directory Hierarchy
What is a good simple rule to enforce with new users within the Trusted Extension System?
Keep your
password private.
Write your password on the monitor.
Announce your password to your friends and loved
ones.
Include your password as a signature in your
emails.
pkgadm can display the following certificate type:
Trusted
All are correct
Signing
None are correct
What can be called discrete rights to processes that perform operations?
Total access.
Privelages
Operational accessories.
Secure accommodation.
Which command allows you to update your current password?
passwd (*)
passupd
changepass
password
Which of the following is TRUE about /bin/ksh ?
Indicates the Z shell
Indicates the C shell
Indicates the
Korn shell
Indicates the Bourne shell
What will auditing tell you about a Solaris system's security?
It will tell you
about changes made to the system.
It will tell you how many viruses are on the
system.
Auditing tells the user how fast they can secure
their system.
Auditing tells you how well your disk is encrypted.
You can use Patch Manager to perform the following on your system:
Apply patches according to system policy
Download patches onto the system
Analyse it and determine which patches are needed
All are correct
When installing a non-hot-pluggable device, what must you do before installation?
Wait for the system to idle.
Shut down the
system.
Short the motherboard circuit out to make it safe.
Nothing. Just do it really fast before the
electricity reaches the circuit.
Is it possible to log in via serial port?
Yes.
Yes, but access must be granted via the VGA port.
No.
Yes, but you must also be connected via usb port.
Which of the following commands can be used for remote copying?
rsh
rcp
ftp
rlogin
What is an example of a protocol used on Solaris' network layer?
IPv4
Piv4
IP_4
lyrIP
What is an example of an encrypted authentication service within Solaris?
Kerberos
SeLinux
Arkcellos
Enigma
What is a UNIX File System (UFS) ACL, and what does it do?
Access Control Lists are lists of files that are
safe to edit.
Access Control
Lists restrict or grant read, write, or execute access to specific users or groups.
Administrative Control Liasons use hardware to
prevent unauthorized access to the system,
Access Control Lists prevent certain users from
using the system.
What command is used to configure Solaris' multipathing support?
mpathsolaris
pathtooladmin
mpathadm
multipathtool
Solaris 10 OS stores user account and group entry information in the which of following system files?
/etc/passwd
/etc/passwd
/etc/shadow /etc/group
/etc/group
/etc/shadow
To find only those files larger than 400 blocks in the current working directory, you use:
find . -exec ls -s \; -print
ls -ls | grep 400
du | grep -e "4??"
find . -size
+400 -print
Within the Solaris Operating System, what is the first line of defense to protect the file system?
Default UNIX
permissions assigned to every file system object.
Reboot the system.
Turn off the system.
Compress every file and folder on the system.
Within the Solaris Operating System, what are authentication services used for?
Greeting users who use the system.
They are used to authenticate services.
Encouraging more users to use the system without
security measures.
Secure
identification of users via password, or other forms of identification.
You suspect an unauthorized use of the “su” command. Where do you look and what would it tell you?
“/var/admin/logs”, and it tells you information
about unauthorized users.
“/sys/logs/masterlogs”, and it contains every log
file in the system.
“/usr/adm/sulog”, and it shuts down all su
privelages.
“/var/adm/sulog”,
and it tells you every use of the “su” command.
What are the benefits of NFS?
It shares executables and data files
It shares common read only file systems
It shares host names over network
All of the given
options are valid benefits
To add a new attached printer you use:
Solaris Print Manager
LP print service commands
Both Solaris
Print Manager and LP print service commands
You need to prevent the new staff from performing “console aborts”. How do you do this?
It is impossible to prevent console aborts.
Console aborts are encouraged to retain data
integrity.
There is no need to prevent console aborts.
Change the value
of KEYBOARD_ABORT to “disable” in the /etc/default/kbd file.
The following crontab file (besides root) is stored in the /var/spool/cron/crontabs directory:
uucp
sys
all are correct
adm
Which of the following commands can be used to ping a host?
ping
pngn
png
pinging
What is the outpout of svcs -d name_of_service command?
List all the processes this service is running
Service status
Returns the location of service logs
List all the services
this service is depended upon
In the context of Solaris, what are SAN devices?
SAN devices are PBX devices such as telephones and
answering machines.
SAN devices are used to convert your hard disk to
beta max format.
Storage area
network devices are storage devices in a high-speed network that are also
connected to servers.
SAN devices are various kinds of tape drives.
For managing terminals and modems, you use:
Service Access Facility (SAF) commands
Both
Solaris Management Console’s Serial Ports tool
Which of the following command will output the default shell for the current user ?
ifconfig $DEFAULT
echo $DEFAULT
echo $SHELL
ifconfig $SHELL
To view the system's Solaris Release Information you:
use the Solaris Information Manager
display the
contents of the /etc/release file
use the sacadm command
execute the command: whatis -V
Which of the following command can be used to see the detailed boot sequence?
boot -seq verbose
boot -m verbose
svcadm -seq
svcadm -m
What is the difference between RAID-0 (Concatenation), and RAID-0 (Stripe) Volumes?
Concatenated RAID-0 writes to the last available
component, Stripe writes to the first available component.
RAID volumes are encrypted, while Stripe volumes
are compressed.
There is no difference and they are directly
interchangeable.
Concatenated
RAID-0 writes to the first available component, while Stripe distributes the
data equally across all components.
The International Organization for Standardization designed the OSI Reference Model that uses structured layers. What does the acronym OSI mean?
Open Standards International
Open Systems
Interconnection
Operating Systems International
Only Systems Interconnection
To display the size of one or more directories, subdirectories, and files, you use:
the du command
the fuse command
the fileinfo command
the df command
Which of the following field in /etc/passwd represents user primary group?
UID
GID
grp
uucp
Which of the following is NOT a valid output for command : echo $SHELL
/bin/ksh
/bin/sh
/bin/tch
/bin/bash
Which manages all the physical resources of the computer?
Shell
Processor
CPU
Kernel
To display a system’s Host ID number you use:
the hmadm command
the hostid
command
the who command
the host command
Solaris is what kind of operating system?
Linux
Windows
Unix
SunOS
Which of the following Solaris 10 command will list all configurable hardware in the system?
configadmin
cfgadmin
configadm
cfgadm
To automatically execute system tasks, you use:
all are correct
at
crontab
none are correct
Which of the following commands can be used to capture network packets?
capture
nwpackets
nwpckt
snoop
If you are on a stand alone system, and you want to bring it to single user mode, you execute:
init s
init 3
init 0
init 6
What is location that your project database definition would be stored?
/etc/newswitch.conf
/etc/newswitch.conf
/etc/nsswitch.def
/etc/nsswitch.conf
Do you have to be a super user to install a device to your Solaris system?
Any user can install a device to the system.
Yes.
You have to be a guest user with permissions that
supersede the super user.
No.
The '-g' switch to the shutdown command is followed by:
grace time in
seconds
grace time in minutes
groups to be notified of the shutdown
groups which may abort the shutdown
If you add a user to a group while they are already logged on, what do they have to do in order to be able to access files owned by that group?
Run the "groups" command.
Log out of the
shell and back in.
Change their password.
Nothing, they will immediately have access.
What is the default difference between run levels 2 and 3?
Run level 3
starts NFS services
Run level 2 starts NFS services
Run level 3 starts a web server
Though the traditional UNIX crypt algorithm is insufficient for current systems, why is it still utilized?
Solaris wanted to leave a back end open for
government officials.
For the sake of
backwards compatibility.
It was far too expensive for Solaris to keep it up
to standards.
Unix is slow to update their crypt algorithms.
To list the total number of physical processors on a system, you use:
psrinfo -p
proc -v
enumerate -P -v
what -p
To set up a terminal, you use:
the Solaris Print Manager
the Solaris Terminal Manager
the Solaris
Management Console
the Service Access Facility
Which of the following is TRUE about following command and the option: useradd -u 800 -g TEST
UID number for the new user : 800 Secondary group
for the new user : TEST
UID number for the new user : TEST Primary group
for the new user : 800
UID number for
the new user : 800 Primary group for the new user : TEST
UID number for the new user : 800 User name for the
new user : TEST
What is the name of the daemon that handles FTP transfers?
in.ftpd
ftp.123
ftp.daemon
in.tftc
When setting up a volume in VTS, what data storage scheme does VTS use?
SATA
FAT32
NTFS
RAID
When exporting a ZFS storage pool, what effect does the “zpool export tank” command have, and what can be done in the event of a failure?
“zpool export
tank” attempts to unmount any mounted file system. The -f option is used to
forcefully unmount file systems in the event of a failure.
“zpool export tank” encapsulates malicious code in
a sandbox. If the system fails, unplug the server.
The “zpool export tank” command forcefully shuts
down the system and encrypts the hard disk.
“zpool export tank” remounts the system, and -f
induces system shutdown.
You have been assigned the task of interpreting VTS probe errors. Where do you find them?
system/vts/probe/errors
vts.probe.errors
etc/user/errors/vtsk
/var/sunvts/logs/vtsk.err
What command would you use to restart the SSH server daemon on Solaris 10 using the Service Management Framework (SMF)?
inetadm restart ssh
/etc/init.d/ssh restart
svcadm restart
ssh
svcs -r sshd
If you need to shut down Solaris in 30 seconds for an installation, what is the command?
seconds-30
-g30
-s30
-time30
Which of the following Solaris 10 command scan for new devices?
devfsadm
devsadm
scan
devfadm
To create a soft partition, what parameters are needed with the metainit command?
Metainit [-s set] soft-partition p -e componentsize
m# [-s d#] soft-partition -p [-e] component *s*
metainit [-f disks] soft-part -p [-e] component
state
metainit [-s
diskset] soft-partition -p [-e] component size
When tuning Solaris, does one system's /etc/system settings govern another systems environment?
No.
Yes, but only marginally.
Yes, all settings are global within a network.
Yes, even settings changed on disconnected systems
will be altered.
Which of the following is the default shell for root user in Solaris Operating System ?
Korn
C
Bourne
Borne
Which of the following is a default shell for root user?
C
korn
Z
bourne
Which of the following are main components of SunOS operating system?
Kernel, Shell
and Directory Hierarchy
Directory Hierarchy
Shell
Kernel
Which of the following command can be used to stop a running service?
svcadm -s name_of_service
svcadm disable
name_of_service
svcadm kill name_of_service
svcadm stop name_of_service
If '-1 < N < 7', Scripts in /etc/rcN.d are executed in:
creation order
ASCII order of
their names
accordance to comment on '#!' first line
accordance to their ownership
To apply patches to a machine, you use:
smpatch
All are correct
None are correct
the Solaris Management Console Patches GUI tool
The tnd daemon pulls tnrhdb and tnrhtp information from the LDAP directory and local files. What governs the order that they are loaded?
Their order in the ldapload.conf file.
They load at the same time.
Their order in
the nsswitch.conf file.
Their order in the loadingorder.conf file.
If you are at the PROM level (you pressed stop-A and got to the ok prompt), and you want to start the system from the Solaris DVD-ROM disk, you use the command:
boot dvdrom -s
boot cd
boot dvd
boot cdrom -s
To remove entire temporary directories, you cd to the temp directories, then use the following command:
rm -r /*
rm -r *
find .. -type d -exec rm {} \;
rm *
To remove a crontab file, you use the command:
rm /etc/cron.d/cron
crontab -r
rm -f /var/spool/cron/crontabs
rm /var/spool/cron/crontabs
On a newly installed Solaris system, the script /sbin/rc4 performs the following actions contained in the scripts in /etc/rc4.d:
None are correct
Starts smdb and nmdb
Starts the htt_server process
Starts pppoed or pppd daemons
Which of the following is TRUE for files /etc/hosts.equiv and $HOME/.rhosts?
They run first during install
Thery are
related to system security
They are created by default during the installation
They can be created by superuser only
Crash dump files are created in the directory:
/crash
/var/crash/
/var/core
/var/dump
What system resource call specifies the total number of files that can be assigned by the open(2) system call?
open(2)sys.max
max-file-call
process.max-file-descriptor
max.open.file
Which of the following is a user profile for a user with Bourne shell as a default shell?
.prof
.profile_bash
.bash_profile
.profile
How can you get the WWN info about the HBA ports in a system under Solaris 10?
getinfo hba
fcinfo hba-port
prtdiag -v
hbainfo --WWN
Once you installed a software package, you can check if the installation is correct with:
pkgadm -c
pkgverify
pkginfo -V
pkgchk -v
What directories are included in the root path?
/usr, /share, /etc
/usr/gnu/bin:/usr/bin:/usr/sbin:/sbin
/bin, /root, /mnt, /lib
/run, /dev, /lib32, /boot
What does system mount option (Solaris 10) nodevices signify?
To disallow the
opening of device-special files
Disallow clients from mounting sub-directories of
shared directories
Disallow write access to the file system
Disallow the execution of programs from the file
system
Which of the following directories contain kernel?
/etc
/usr
/
/, /usr and
/platform
If the repository of the SMF (Service Management Facility) has become corrupted, you can stop the svc.configd daemon with:
kill -1 svc.configd
pkill
svc.configd
kill -9 svc.configd
kill svc.configd
Which of the following command will delete the password for user "test" and prompt for a new password on login?
passwd -df test
password -df test
passwd -d test
passwd -f test
To display the total number of blocks that are contained in a directory, you use:
du -s
du -h
df -h
df -s
How do you list all of the zones that are configured on a system?
listzones
zones list
zoneadm list all
zoneadm list -c
If you are at the PROM level (you pressed stop-A and got to the ok prompt), and you want to check the revision number, you use the command:
revision
banner
version
promrev
Which of the following is TRUE about ROOT USER?
User ID=1, Group ID=1
User ID=0, Group
ID=1
User ID=0, Group ID=0
User ID=1, Group ID=0
Where are the details displayed by the ls -l command stored?
The inode for
the file. (*)
The inode table.
The directory header
The file header.
Which of the followiing commands can be used to change the priority of a process?
proc
priocntl
priority
nice
To check the status of active processes on a system, you use:
prstat
pkill
all are correct
pgrep
What must happen before logging into the system?
The user has to use their default program to enter
the system without logging in.
The user must log in to the system, and set a
default project.
A default
project must be assigned to the user.
The user must press their hand against the monitor.
Which of the folllwing files contain user passwords?
/etc/group
/etc/shadow
Both /etc/passwd
and /etc/shadow
/etc/passwd
Because the command, “mpathadm modify” is only effective while the system is running, what must be updated to retain changes that are made after a shutdown?
/kernel/disc/scsi_vhci.conf
/kern/drv/scsi_vhci.conf
/kernel/config/scsi_vhci.conf
/kernel/drv/scsi_vhci.conf
What is Oracle VTS?
It is an Oracle
validation test for hardware diagnostics.
Oracle Variable Transaction System for managing
memory.
Oracle's Video Testing Suite
A varification testing suite.
What is the outpout of svcs command?
List all available services
List all the processes
List all failing services
List all active
services
If users want to perform drag-and-drop operations, what must be true about the source and target label?
They must be linked.
They must be the
same.
They must be different.
The target must be hidden.
Which of the following is an INVALID control for password management in Solaris 10
DICTIONLIST
HISTORY
NAMECHECK
PWDPOLICY
Which of the following shell is a superset of the Bourne shell with C shell-likeenhancements and additional feature?
TC
Bash
Z
Korn
If you want to view information on the certificate you have stored in the package keystore, you use the command:
pkgcert list
pkgadm --list
pkgadm listcert
patchcert list
By default, the package keystore of a signed packages that is used with pkgadd and patchadd, is stored at:
/var/sadm/patch
/var/adm/pkgs
/var/sadm/security
/var/sadm/pkgs
To remove a software package you use the command:
pkgadm -d
pkgrm
pkgdel
all are correct
On a SPARC system, if you want to create a crash (core) dump, you do:
mkcrash
core -c
dump
halt -d
If you are at the PROM level (you pressed stop-A and got to the ok prompt), and you want to get to run level 3 (without a reboot), you use the command:
init
init 3
boot
reset
Which of the following Solaris 10 command will list all open TCP connections?
netstat -o inet
netstat -l inet
netstat -f inet
netstat -d inet
Which of the following Solaris 10 commands can be used to create an alias temporarily?
temp
alias
ifconfig
echo
On an inittab File the line starts with 'p3:', if the third field is 'respawn' it means that:
The process indicated on the second field is
started
The process indicated on the last field is
restarted when it dies
The process indicated on the last field is killed
if it is started
The process
indicated on the last field is started, and restarted when it dies
All are correct
To set the hard and soft limits on the number of inodes and the amount of disk space for each user, you use:
edquota
quotaon -s
quotach
quot
To install a package non-interactively, by default you can set an response file to the 'pkgadd -a' command in:
/var/adm/install/pkgs
/var/sadm/install/admin
/var/sadm/pkginst/auto
/var/sadm/pkgs
Which of the following is not a function of the harness (VTSK) in VTS' agent layer?
Logging of messages
Updating status messages.
Encryption of
messages.
Handling of different user interface commands.
For a service called SSS, to inspect its properties you do:
inetadm -l SSS
properties -s SSS
svc --list SSS
svc.inspect SSS
Instead of using the pprosetup and pprosvc commands, it is better to use the command:
patchadm
smpatch
pkgadm -p
pkgadm -P
To verify that a printer's banner page is optional on printer printer-name, you should look for the output line "Banner not required" in response to:
lpstat -P printer-name -v
lpstat -p printer-name
lpstat printer-name -l
lpstat -p
printer-name -l
When applying patches with Patch Manager, you
Do not need to set up the keystore and certificates
manually
Do not need to set up the keystore manually but the
certificates are handled manually
Need to set up
the keystore and certificates manually
Need to set up the keystore manually but the
certificates are handled automatically
In order to use the 'smpatch add' command, your system should be in:
multi-user without networking mode
single-user mode
PROM (ok prompt) mode
any run level is okay when installing patches
All are correct
If you want to get a list of all software packages installed on the system you use:
pkglist -a
pkginfo
pkginfo -l -a
pkginfo --all
Which is not a tunable parameter in Solaris?
Range
Range
Configuration
Implicit
Commitment Level
Which of the following Solaris 10 commands can be used to create a permanent alias?
temp
alias
echo
ifconfig
You can change the locales on your system without reinstalling the OS or manually adding and removing packages, using the command:
chlocale
locale
localeadm
localeset
Which of the following commands will output all the interfaces to a system?
ping
netstat
ipconfig
ifconfig
After the cron daemon executes an at job, the at job’s file:
is moved to /var/spool/cron/
is moved to /tmp
stays the atjobs directory, but is no longer
executable
is removed from
the atjobs directory
The equivalent of using the following three commands: smpatch analyze, smpatch download, and smpatch add, is to use the command:
smpatch update
smpatch install
smpatch apply
patchadd -u -a -i
What does command ps print without option?
all process
all jobs belong
to the user
all process belong to the user
all jobs
To display information about how disk space is used, the following is employed:
the df command
the diskuseage command
the diskinfo command
the du command
To schedule single (one-time) system tasks, you use the following facility:
at
crontab
systask
schedule
To list all users of each mounted UFS file system and the number of 1024-byte blocks used, you employ:
users -F ufs
du -a -u
quot -a
who -d UFS
To determine whether a system has 32 bit or 64–bit capabilities enabled on x86 based systems, you use:
the isainformation command
all are correct
the isalist
command
the archinfo command
The Service Access Facility enables you to set up ttymon and listen port monitors by using:
the ttyadm command
the sacadm
command
the nlsadmin command
the pmadm command